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1 Position Sensor Simulation

1.1 Introduction

The correct measurement of an angular position (or speed) is required in many different applications. One of
the typical realization principle is based on the evaluation of the magnetic field quantities which are effected by
moveable (rotating) permeable region nearby. Many of such applications are using a difference signal of 2 field
sensors(e.g. Hall or MR elements) to measure the H-Field showing reluctance effects (for static methods) or
eddy effects (for dynamic effects).

A well known application of such a principle using MR-elements is shown in figure 1. Here cylindrical
permanent magnet works as a field source for the 2 sensor elements and the structured rotating wheel.

Sensors

Permanent Magnet

Figure 1

While the field source remains constant, the magnetic resistance depends on the angular position of the
structured wheel.
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Figure 2 gives a more detailed picture of the region of interest (sensor region). As the size of the sensors is
significantly small compared to the wheel, the simulation needs to evaluate the field distribution with care.

Wheel

>
Sensors —>

Permanent Magnet

Figure 2

The goal of the simulation is to determine the field quantities with respect to the angular position of the wheel.
In some further optimization runs — the difference signal should be optimized, while the magnet size should be
minimized.

1.2 First Steps (initial Settings of Workbench)

e Open ANSYS Workbench

e Set the Language to English: Tools > Options... > Regional and Language Options > Language >
English

e Close ANSYS Workbench, that the language changes become active

e Open ANSYS Workbench again.
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1.3 Setting up Sensor Simulation

e Insert a new Maxwell3D Simulation (from analysis systems inside the project page)

e Open Maxwell3D (double-click onto the analysis system)

The figure shows the GUI of ANSYS Maxwell:

Modeler
= .
Project Window

Manager

j Message Manager
I

Progress Window

Figure 3
Modeling Setup

e Import the Geometrie (Parasolid): Modeler > Import... > SENSOR_GEOM.x_t
& bmport Fie
Suchen in: I L Test j - EF Eiv
e Name : Anderungsdatum Typ Grofe
Zuletzt besucht . sens_prace files 24,09.201315:59 Dateiordner
) ||| SENSOR_GEOM.x_t 21.09.2013 19:07 X_T-Datei 93 KB |
Desktop
II_
Bibliotheken
LY
Computer
“
Netzwerk
Dateiname: |SENSOR_GEOMx 1 -] Offnen
Dateityp: |NI Ansoft 3D Modeler Files {*.sm2;”".gds;”.sm3;" sat;" stp; “step;”igs; “iges;"dd; ‘.dwg“.sld:LI Abbrechen |
Personallib I Userlib |
Walidation and Healing O ptions
 Huick.
% Strict % futo " Manual
4
Figure 4
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e Save the Workbench Project: File > Save As... > SENSOR_GEOM.x_t.wbpj
e Open the Maxwell3D component system

Assign Material Properties to all Solid Parts:
e Point onto the Magnet (inside Solid Tree or within graphics window)
e Use RMB to choose Assign Material

53 Fde €t View Projct Oraw Modeler Muowel30 Took Window Help

[DE@ sl & xoc |57 2 o |geenlp |"C32® 2% 0@ o |8 a5 8388
g lele x| 0@ | |00 [0St |8 fowm ] |[Mose O & | e R
|ov M & | VL O lcocoeod|leBROO®S 2R

Project Manager 2% 5@ Sobds

= () Maxwell Progect” & M Not Assigned

= G4 Maxweli 30Design1 (Magnetostatic)” EX ' ey
O Dot @ ReG  Sollapsen

SEN £dn »

12
@ le, Coordinate  Yiew ¥
= 4B Planes Properties...

& @ Lists Assign Boundsey »
Assign Excitation 4
_Project | Assign Parametess »
Assign Mesh Operation  »
Propertes X Fields »
Name | Vehe | Unt | Evahusted Vake |
| [Mame MIGNET
Matosal .
Solve nsde r
| Orertation Global
Model 2
Diaplzy Wiefr @
Cotor —
Transparert 0
Figure 5

e Insert “NdFE” into the material name box to search for existing data sets

Select Definition (=]

Materials | Material Fiters |

— Search P

Search by Name Search Criteria libraries ™ Show Project defiritions W Show all libraries

IND| @ by Name " by Property
Goach | IReIative Pemittivity LI

N Relative Bulk &
/ me Pemeability Conductivity

MNdFe35 SysLibrany Materials 1.0957785406 625000siemens./m -t
Melco N4DD0-13 ¢m) SysLibrany Materials 1 0 0
Melco N4000-13 SI ¢tm) SysLibrary Materials 1 i} 0
Meltec MH3254 {tm) SysLibrary Materials 1 i} ﬂ,:l
Mettec NHI300 {m) SysLibrary Materials 1 0 0
Mettec MHI320 {m) SysLibrary Materials 1 [1] 0
Metec NHS338 {m) SysLibrary Materials 1 1] 0
Meltec MH3348 ¢tm) SysLibrary Materials 1 i} 0
Meltec MH3350 ftm) SysLibrary Materials 1 i} 0
Mettec NX5240 ¢m) SysLibrary Materials 1 0 0 i

] T | 3

View/Edt Materials Add Materal .. | Clone Materialls) Remove Materalis) | Expottto Lbary... |

OK | Abbrechen | Hife

e Accept the material with OK
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You may check the content of the material data (from Library) — as well as adjust settings with the View/Edit
function. Here you can see that the magnetization direction is oriented as global X direction. This setting is
correct for our analysis here.

Proceed similar for the other solids, to point vacuum to the sensors (the are non magnetic regions) , as well as
the region. Choose “Iron” from the library to point onto the wheel. For the first analysis the linear description of
iron is suitable here.

The graphics properties can also be adjusted for each solid. You may use the Properties Window (left side under
the tree) to adjust colors and transparency. Moreover also the use of the solid within the simulation can by
specified (Model or Non-Model).

% File Edit View Project Draw Modeler Maxwell3D0 Tools Window Help

BRR & X oo (= -] 7

2N i0 e & v oo o 3 §pood
P D J=ReNol
Project Manager 2| @47 solids

EI! Mot Assigned
&P iron
€7 WHEEL
-4 vacuurn
m-£7 REGION
€7 SEMS_BACK
£ SENS_FWD
m-le, Coordinate Systems

= Maxwell Project™
#-§i Maxwell3DDesign1 (Magnetostatic)”
-2 Defintions

-4 Planes
w68 Lists
Project |
Properties - %
MName | Value | LUnit | Evaluated Value
MName MAGMET
Material
Salve Inside [
Crientation Global
Model [w
Display Wirefr... [
Color —
Transparent 0 |
Figure 6
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As the next step, the boundary condition should be set. Thus its helpful to rotate the model. This can be done

with the middle mouse button, while the scroll-wheel helps for zooming in and out.

Assume the field at the end regions of the sector of the wheel are not effected by the magnet — a flux parallel

boundary condition (natural) is sufficient for the basic setup.

The definition of initial mesh parameters help to improve the performance and accuracy. For this step a sizing

for the sensor region is required.
e Select the Sensor Solids

e Use RMB to choose Apply Mesh Operation > Inside Selection > Length based

[\ ANSYS Maxwell - MaxwellProject - Maxwell3DDesignl (Maxwell 3D Design) - 3D Modeler - [MaxwellProject - Maxwell3DDesignl - Modeler]
i File Edit View Project Draw Modeler Mawell30 Tools Window Help

IDEd| B & Xac |[8 o |leEeeR o Imc3ssa@
Il le| . <o dloeeomd | h | | a2 th | B |[ecom i

| <] IO [~ 3 D lmocood |eBROOS® R
Project Manager x| [5°@ Solids 1
= (1] MaxwellProject* = 4 iron
@ §4 Maxwell3DDesign1 (Magnetostatic)” @& WHEEL
@ (2] Defintions = B NdFe30
@ & MAGNET
= 4B vacuum
& & REGION
R4 SENS_BAC
CR -7 SEN e
@-lz. Coordinate Expand All
5 & Planes Coliapse All
@ € Lists Edit R
_me_d_l B Assign Matesial...
Properties - X View 3
) Properties...
l e l = l EX0 e e Assign Boundary 4 A
p . - . - Assign Excitation >
e - i Assign Parameters »
ive bake 2 Assign Mesh Operation On Selection L
Oriertation Global — = {
Fields » Inside Selection >
Model [v :
Drsplay Wirefr [ Surface Approxamation...
Color [ ] ?:c;del Re‘slo‘lsmno:...
yhindrical Gap Trestment...
Transparent 0 :
Figure 7

e Specify 0.02 mm

Proceed similar to define 1mm for the magnet and 3 mm for the wheel.
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As the basic setup is nearly finished — the analysis setup can be implemented:
e RMB in Analysis > Add Solution Setup

@AHS"I"S Maxwell - MaxwellProject - Maxwell30Designl (Maowell 30 Design] - 30 Modeler - |
5 File Edit View Project Draw Modeler Maowell 3D Tools Window Help
D@ d B & X |[a]2 2 “|®
e le & ke | I
|6 1 2 ER R lecoe
Project Manager % | =& Solids
= (1] MaxwellProject” = fi§ iron
= ¥ Maxwell3DDesign1 (Magnelostatic)® & &P WHEEL
&P Wodal = P NdFe3)
EF Boundaries &7 MAGNET
B Excilations = ¥ vacuum
8t Parmmeters @-€F REGION
& BE Meash Operations a-£ SENS_BACK
B 5-&? SENS_FWD
= % Clmj,-'_ - : 112 Coordinate Systems
[7) Res| Add Solution Setup... |& @ Planes
‘ Fsid List... 1 Lists
[ )
Figure 8

The original setup shows 10 adaptive iterations to fulfil the energy criteria (global)

Solve Setup

General | Convergence I Expression Cache I Sul'u'erl Defaults I

Mame: Setup 1 v Enabled

— Adaptive Setup

Mazdmum Mumber of Passes: I'H]'

Percent Emor: I'I

— Parameters

[~ Solve Fields Only

Solve Matre:  ©* After last pass
= Only after converging

Figure 9
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The validation checking can be used to validate of all requirements for the analysis are fulfilled.
Use the appropriate function from the main menu.

Validation Check: MaxwellProject - Maxwell3DDesignl ==
_ o Design Setings
J b awell 30 Dezign o 2D Modsl
¥ Boundariez and Excitations
¥ Parameters

Walidation Check. completed.
¥ Mesh Operations

| & Analyziz Setup
o Optimetics

Abart | Cloze I

Figure 10

Next the analysis can be started.

£ ANSYS Maxwell - MaxwellProject - Maxwell3DDesignl (Maxwell 3D Design) - 3D Modeler - |
B File Edit View Project Draw Modeler Maowell3ID Tools Window Help

i - I B & = Iq ¥ o3 ~|ms | o
e ol AR =] |
l& 5 = [~ 3 D loooe
: = X| |E-&? Solids
= [ MaxwellProject = 4 iron
= i Maxwel3DDesign1 (Magnetostatic) #-¢ WHEEL
& Model = P MdFe3l
EF Boundaries & MAGMET
0 Exchations = I vacuum
Fe Formmetens &£ REGIOM
=-BE Mesh Operations 5 SENS_BACK
F- SP Analysia &P SENS_FWD
. FE {l¢, Coordinate Systems
i Bny Copy Ctil+C
-] Optime - ) Planes
I [F] Resut : Lists
‘ Fsld C Rename F2
&[] Defirtions 2 Delete Delete
Properties...
Dizable Setup
] | Analyze
Figure 11
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The simulation progress can be seen on the main screen — showing also the adaptive iterations.

e =T

L) 7 Z e
X e €6t View Project Draw Modeler Manwell30 Tooks Window  Help
Lo |58 38383

2c Bz Imple@en o|BiNcSTcSo 86 (@

ID=a 8 &>
lew lo|. @ | losih 108 Pizn 18 e ZAFe 3 ss 145
ICE R frnu 3 ne jccocdieBBoCcE®= 2R
Prosect Harmos = %] [2°8 sois
5 1] MaxwellPropect™ = 8 won
1 B Mazwoll 30 Design | (Magnetost atic)” - &P WHEEL
& Model = M NFe3)
F Boundsses &P MAGNET
43 Excranons = B vacuum
$ Perameters & & REGION
-8 Mesh Operatiors. @ &P SEMS_BACK
= 7 Prelyss P SENS_FWD
£ Sent 71 L, Coordinate Systems
(@) Ootimetics. 14 Planes
Resut & Lists
i Pk vy
-3 Defnaorn
¥,
Froperies oz
Teme Tvoe]_Ure [ Evaied®
Hame
cratied =
Max. Number of Passe: 10
Percant Eor 1
- o 25 50 (mm)
. | MamvetPotect ~Setupl. Adapive Pass |
E} FactorEst memaey = 77MB, diek = 1HE]
kil 4
i :
s I zu‘::na

IS AR
Figure 12

The convergence can be check with:
e RMB Analysis Setup1> Convergence

i1 Solutions: MaxwellProject - Maxwell2DDesignl El@ .
Simulation: ISetup'I ;I

Design Yanation: I

"Profile  Convergence | Force | Torque | Matrix | Mesh Statistics |
Passl # Tetrahedral Tatal Energy [.J]I Energy Error [Z]l Dielta Energy [Z]I

— Mumber of Passes

Completed 3 1 26874 0.0034917 2 8066 ML,
Masimum 10 2 34340 0.0085952 05942 1.2196
Mirimum 2 3 45430 0.0086139 0.3285 0.21757

— Erergy Eror/Delta Energy (%)

Target [1.1)]
Current  [0.3285, 0.21757]

Wigw: * Table " Plat

Ewport... |

Close |

Figure 13
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To proceed with some further steps, it may be helpful to hide the field region. This can be done with the “eye”
filters in the main menu.
ignl - Modeler] =T

-8 X

Figure 14

Resulting to the picture of figure 15.

Z

L
0 15 30 (mm)

Figure 15
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Insert a field-plot to display the magnetic field of the wheel.
e Select the solid body of the wheel
e Use RMB to choose Fields > H> Mag_H

v | Select Objects ]
Select Faces F
Select Edges E
Select Vertices v
Select Multi M

All Qbject Faces

Go to History

Measure »

View »

Edit » H

B Assign Matenal... B

Assign Boundary » J

Assign Excitation » Energy
» Other
»

Named Expression...

Assign Parameters

Assign Mesh Operation

Fields Marker »
Mg E——

Figure 16

| Mg H
H_Vector
e

30 (mm)

e Check the Box “on surface only” to create a contour plot

Create Field Plot

[~ Specify Name IMag_H1

[ Specify Falder IH LI

Design:  Mawwell3DDesignl

— Caontext

Solutiot: ISetup1 : Lastidaptive LI

Field Type: |Fisids =~

Intrinizic Y ariables

Save bz Default |

Fields Calculatar ... |

Categony: IStandard
Guantity

Mag H

H_%ector

Mag_B

B_“ector

Mag_J

J_Wector

Energy

coEnergy

appE nergy
Ohmic_Loss
Temperature
Yolume_Force_Density
Surface_Force_Denzity
Mag_Displacement
Dizplacement_ector

Done I Cancel

=

In Y olume

WHEEL
SENS_BACK
SENS_FwD
MAGMET
REGIOMN
All0bjects

W Plot on surface only

[~ Streamline

Figure 17
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The resulting field plot should look like figure 18. The field is concentrated to the region near to the magnet
and will be symmetric, as the initial position with respect to the structure of the wheel is also symmetric.

Z ¥

H[A_per_meter]

G, 247 9e+0@1
. 7. 7325e+8@1
7217 1e+881

6. 701de+0@1
6, 1864e+081
5. 6718 +EE1
5. 1556e+E@1
4, B4 3e+0E1
4. 1249 +EE1
3. 6B95e+8@1
3. @94 1e+0E1
2, 57G0e+0@1
2, 8634 e+0a1
1. 5450 +8E1
1.8326e+8@1
5. 1727 e+Ea0
1.8992e-082

Figure 18
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1.4 Sensor Parameter Setup (Calculator)

As the sensor signal is derived from the magnetic field in the region of the sensor domain, the field calculator
of Maxwell will be used to determine this data.

-

e Select Field Overlays (in tree) > RMB Calculator

1] Fields Calculator |E|
Mamed Expreszions Contest: bagwel 30D ezsignl
Marne | - Saolution: |Setup1 : Laztddaptive j
tag_H Mag(Smoath[<H = . -
Field Type: Field
tag B M ag[Smoothl<E J e | == J
tag M ag(Smmoathl<. Clear Al
H_Yectar Srnaathl<Ha«,Hy
P T b
add.. | |
Library: Load Fror... ‘ Save To.. | Lhange Vel Valbes..
A
Psh |  Poo | Awe | RDn | Exen | Cea | Undo |
It General Scalar Wector COutput
Quartity ¥ | + | Yec? ¥ | Scal? ¥ | YWalue |
Geometny. . | | 1/ | datl... | Eval |
Constant ¥ | = | Pow | tMag | Writke |
Mumber. .. | 4 | I | Dt | Export |
Function. .. | Meg | Trig hd | Crozs |
Geom Settings...| s | wa | Diva |
Read... | Smooth | S | Curl |
Complex ¥ | Min * | Tangent |
Dromain | Max ¥ | Mormal |
i | UnitWec ¥ |
Ln | #Fam ¥ |
Log
Figure 19
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The equation in figure 20 shows the relation that should be evaluated with the field calculator for both sensors:

>ens_Fwd

[Hidrflf'ﬁl
a=tan"| ST——m— | |
|Hdviv | |

Figure 20

For the Forward Sensor (FWD)

e Qty * H *Scalar = Y

e Geom * Sens_Fwd * Integ
e Qty * H = Scalar = X

e Geom * Sens_Fwd * Integ
. /

e Trig = Atan

e Constant * Pl =/

e Number = 180.0 - *

e [Add] - Ang_Fwd

And also for the Backward Sensor (Back)

e Qty * H *Scalar = Y

e Geom * Sens_Back * Integ
e Qty = H = Scalar = X

e Geom * Sens_Back * Integ
o /

e Trig = Atan

e Constant - Pl =/

e Number = 180.0 - *

e [Add] - Ang_Back

Finish with DONE.

o)

Sens_Bach

¥

I::::::I
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The evaluated quantities can be displayed with:
e Results RMB> create field report > Data table
e Choose from the calculator expression ANG_BACK and ANG_FWD
o New report

3 AMSYS Maxwell - MaxwellProject - Maxwell3DDesignl (Maxwell 3D Design) - Data Table1 - SOLVED - [MaxwellProject - Maxwell3DDesignl -

B File Edit View Project Report2D Maowell 3D Tools Window Help

&|x o =] o iEweR o B
IR B
Ma @a @

Project Manager . x

&[] MaxwellFroject- ANG_FWD ANG_BACK

-8 Maxwell3DDesign 1 (Magnetostatic)® ) Setup? : LastAdaptive  Setup? : LastAdaptive
..... & Model 1 0.000000 20.953502 -20.951187
¥ Boundaries
-G Excitations
% Parameters
B8 Mesh Operations
[—]ﬁ Analysis
L. P Setupl
[ Optimetrics
[—]--- Results
-] Data Table 1
L ANG_PWD
.7+ ANG_BACK

Figure 21

Insert these variables as convergence criteria:
e RMB Analysis Setup 1 > Properties > Expression Cache > Add
e ADD the ANG_BACK and ANG_FWD
e Done

e Adjust the convergence to 0.05 for each parameter

Solve Setup @

" General Convergence  Expression Cache | Solver | Defaults |

Title | Expression | Context | Intrinsics | Convergence |
ANG_FPWD1 ANG_FWD MNone MNone | 0.05 |

O T e [ e

Figure 22

The next analysis run will also consider this definition.
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1.5 Insert Parametric Rotation of the Wheel

As the sensor detects the field quantities as a function of the angular position of the wheel, a rotation of the
geometry is inserted:

e Select the Wheel and Region !
e RMB > Edit > Arrange > Rotate > type angle into the data field to rotate about z

& Sclids .
= % iron
&P E -
o M NaFey  EPand AN
g e s Lelpse Al
= i vacuui Edit B Copy
F g ::II! Ansign Matenal... B Pate
o SEl Yiew |3 Delete
L2, Coordinet  Properties... Properties...
A Flanes Assagn Boundary v | Amange
& Lists Asdagn Excitatson ¥ Duphicate
Agisgn Pararneten [ Seale
Assign Meth Operation * P——
Fiedds ¥ Boclean
Plot Mesh Sweep
Figure 23

The program will ask for the value of the new defined parameter “angle”:

Add Variable (3w
Name |angle
Unit Type. |Angle |
Unit  |deg =l
vaue B0

Define wariable value with units: "1 mm"

Tupe | Lacal ¥ ariable ;l

QK I Cancel |

Figure 24

Type an initial value of 0 into the field and finish with ok. The parameter could be found and adjusted in details
window (properties) of the Maxwell3DDesign.
This can also be used to check the operation with different values.
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1.6 Workbench Parametric Run

To evaluate the function of the field values (for the sensor) relating to the position the Workbench Parameter

Run can be used (in combination with other physics or the optimization tool OptiSlang)

e Choose Optimetrics > DefaultDesignXplorerSetup

e RMB properties > check include to the variable angle

e Choose Calculation Tab > Add Expression Cache for Ang_FWD and Ang_BWD
e Doneand OK

Save the Simulation Setup within Maxwell (Crtl+S). This will link the Maxwell parameters into WB.

- A

8 7] Maxwell 30
(e
z Setup v

4 | & solution d
25 | (5] Parameters

Maseweell 30 Design

| [pd Parameter Set

Figure 25

Now the parameter sets can be defined and the parametrized analysis could be started:
e Double-Klick onto the Parameter Set
e Type a new value into the empty field under the existing angle (line2 = current design)
e Proceed to define values from -7.5to 7.5
e Use Update Project or Update All Design Points to start a local run of the simulation

ng Extensions Help
glimport... Recormect ¥ Refresh Project | Update Project fesume # Update Al Design Ponts » » »
A | Read modified inputs and generate outputs |~ D E -
1 o Para P1- p2- P3-
2 |E InputParameters | -~ o B E Im | E"‘"’"’"’_
3 | B B Maxwel DDesgn (A1) | 2 | Curent |0 / /
4 | % P [angle | 3 |DP1 | 1 | # #
[ ' I 4 |Dr2 |2 | # #
6 |E OutputParameters 5 |DP3 | 3 | # # |
7 | = BA Mexwel 0 Desgn (A1) | LEIRE " 7 :
s | £ p2 [oecad| 7 _|0P5 |5 [7
5 5 P3 :Emw 8 | DPE | s | # #
" " 9 |oe7 |7 ’ ]
11 | Chats ] w | DP8 D 5 5
Figure 26
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The evaluated curves can be shown also inside the parameter manager with inserted charts:

o Insert Charts
e Choose Angle for the x axis definition
e Choose Ang_Back for y axis 1 and Ang_Fwd for y axis 2

<% Recomnect & Refresh Project 7 Update Project | Resume 7/ Update All Design Points |@REtumthru]E:t @) Compact Mode  © [ CADFEM C.A.V.E.Presenter | . CADFEM C.A.V.E.Frofessional > >
A B A B z D E F -
o Parameter Name B
1 Srame 1| Neme v | P2 v | P2-Ex.. v |P3-Ex.. v || Bpoted Mo v E
2 |2 InputParameters =
B 5 B Mawel 0 Design (3 2 |curent |0 -20.954 20.95
P 1 1 -21.56 20.71
P G P angl [deg] 0 3 d
4 DP2 2 -22.467 21.555 [&]
= fp  New input parameter New name New
5 DP3 3 -23.983 2.737 =
6 |E OulputParameters
3 DP 4 4 -25.491 23.881 [}
7 = G Maxwell 30 Design (A1)
7 DP5 5 -26.412 24.677 a -
5 Fl P2 ExprCache(ANG_BACK1) | 20.
5 7 P scadeine oy | . R ek
o P4 New output parameter New |
harts — B
1 | @ Char - a a EN
12 |1, Parameter chart 0 o o
g a o
= o
gz
é 2
@, o =
o
[
23
<[ i ] e a o 2
Pmpemesufmhemzu * 3 x ||S
Sz o o
a B 3
P2 - ExprCache(ANG_BACKL) o
1 Praperty Vale - o |
2 o |2 R 2
3 Exclude Current Design peint [&] o o o
o
+ ¥-Axis (Bottom) F1-angle [deg] < 26 :
= a - o 2
5 X-Axis (Top) = a o o
3 Y-Auis (Left) P2-ExprCache(ANG BA... =] | T - T
7 Y-Axis (Right) P3 - ExprCache(ANG_FW... | PL-angle [deg]

Abbildung 27
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